APPLIES TO

     
  • DATASTOR Shield™ Scalable Protection Server

  •  
  • DATASTOR Shield™ Enterprise Protection Server

  •  
  • DATASTOR Shield™ Professional for RDX

  •  
  • DATASTOR Shield™ Professional Single Server

  •  

    Build 8.0.608.1

SYMPTOMS

A Windows Server 2003 system may not boot after system recovery, displaying an error on the BIOS screen prior to loading windows, “Windows could not start because of a computer disk hardware configuration problem. Could not read from the selected boot disk. Check boot path and disk hardware.”

CAUSE

The ARC path in the boot.ini file incorrectly identifies the location of the system boot files on the recovered machine. This may occur when a DATASTOR Computer System type plan protects a Windows Server 2003 system that contains multiple partitions, for example an OEM recovery partition in addition to the system partition, but during recovery the same number and mapping of partitions is not recreated. The recovered system then contains a different disk configuration with a different number of partitions. When the system attempts to boot, it reads the ARC path in the boot.ini file for the location of system boot files, which references the original disk layout, not the current disk layout.

RESOLUTION

After the system is recovered using the System Recovery Environment (SRE) and the desired system image, but before exiting the SRE, edit the boot.ini file to reflect the correct boot partition. If you exit the SRE and find that the system will not boot, you can boot into the SRE again to edit the boot.ini file. Steps:

1.Recover a Windows Server 2003 system following the steps outlined in the document, “Computer System Recovery”, available for download at http://www.datastor.com/knowledgebase/explore-features/210-computer-system-recovery-bmr.html

2.Reboot the system. Upon reboot, the system does not boot, in this case. See figure A.

3.Boot into the System Recovery Environment. On the menu, select Open command prompt (Advanced).

4. At the command prompt, type C:\boot.ini and hit enter. The boot.ini file opens in notepad. In this example, the partition parameter is 3 because the system had a 100 MB OEM partition, an OEM Recovery partition, and a third system partition (C:) that contained the boot files. See figure B.



5.In notepad, edit the partition parameter in both the [boot loader] and [operating systems] ARC paths so the partition number corresponds to the partition number on the recovered system that contains the boot system files. ARC partition numbering begins with 1, not 0. If you restored onto the first partition of a disk, edit the partition(n) entries so they read partition(1), for example. See figure C. 

6.In notepad, click the File menu, then Save. 

Note, if the file is marked read-only, the Save As dialog box will open. The file will then save with a .txt extension, which will not resolve the problem. Instead, cancel the Save As dialog box, then remove the read-only attribute of boot.ini at the command line:

 attrib -R -S -H C:\boot.ini, hit enter, then save the file in notepad again. 

7.In the command prompt window, type exit and hit enter. 

8.In the SRE menu, select Restart Computer.

9.The system restarts and boots into Windows Server 2003. See figure D.



STATUS

This issue pertains to DATASTOR build 6.0 and prior versions.

MORE INFORMATION

For more detail on ARC path naming conventions, see http://support.microsoft.com/kb/102873 and http://support.microsoft.com/kb/317526.