APPLIES TO

  • DATASTOR Shield™ Scalable Protection Server

  •  
  • DATASTOR Shield™ Enterprise Protection Server

  •  

    Build 8.0.608.1

SYMPTOMS

Archive Manager may crash when the All Stores folder is clicked on to expand it. An error message reads, 'An entry with the same key already exists.' The text box contains more information: at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value).


CAUSE

Each store residing on a volume has its own unique ID the software uses to identify it. If multiple volumes contain information about a single store's unique ID, the software cannot associate the correct store with the correct volume. It is expected that a unique store ID would be associated with a single volume. In prior versions of DATASTOR Shield, e.g. build 5.0.246.1, an issue caused store unique ID entries to register across multiple volumes in the registry.


RESOLUTION

Review the registry. If two volumes contain a copy of the same store ID delete the invalid entry as well as any invalid Objectstore folder on disk, if it exists:

1. Open regedit and navigate to HKLM\Software\DATASTOR\Volumes. Export the Volumes subkey prior to making any changes.

2. Expand Volumes and look through each volume's 'stores' subkey. To identify the invalid entry, compare the volumes entries and note the duplicate.

To confirm the suspect registry entry is the invalid entry, insert the first cartridge into the RDX dock, e.g. cartridge 841300021500, and view the objectstore folder or folders present. To view the folders on the cartridge, modify folder options to show hidden files, and uncheck the box to hide protected operating system files. If an Objectstore folder with the suspect UID exists on the cartridge, explore into the directory, e.g. use Windows File Explorer to browse to Objectstore{01181ddc-fcbb-4b80-ab63-e03fff23f1d9}. In this case, the invalid folder would be an autoprepared store. An autoprepared store would only have the Config.xml file and Archives subfolder present on disk and would only be a few KB in size. There would be no Common Content subdirectory present. If this folder does contain a Common Content folder, stop. This is a valid store that may contain backup data. Do not delete it.

Once confirmed, 

     
  1. Delete the invalid Objectstore folder on the cartridge.

  2. Delete the invalid registry entry from the right hand pane in the corresponding stores registry entry. 

 

Take care to delete only the invalid Objectstore folder and invalid registry entry